Rear Wiper Maintenance

From AMC Evolution
Jump to: navigation, search

Submitted by AMC Eagle Nest member AMC258

If your rear wiper suddenly quits working, check for broken wires. There is a brown wire and a yellow wire (maybe with tracers, can't tell on mine) that go from under the headliner, out the back above the passenger side hatch hinge, under the hinge, through the hinge hole, and into the liftgate. Mine were broken from the stress of repeated liftgate opening/closing. If you need to repair these wires, please read the warnings about hatch hinge removal posted elsewhere here.

If your rear wiper rubs and chatters on the glass, it is probably due to motor alignment. If you take the trim off of the end of the hatch, you will see the motor. It has two mounting points. One is the wiper arm itself, the other is a screw that runs through a hole in the hatch, and into a nut with a rubber isolator. Check that the nut is on the opposite side of the hatch sheet metal as the motor bracket. If the isolator is worn (bet it is!) the nut may have popped through the hole and you get the fun chore of trying to put it back. Now, make sure the motor is parallel to the deck. With age the mounting bracket tends to bend and prevent parallelism. You can straighten it by pushing on the motor. Try your wiper now, I'll bet it doesn't chatter anymore.

If your wiper climbs over the trim on the top side of the glass, and/or pushes the trim off, the wiper may be installed backwards on the arm.

Personal tools
Namespaces

Variants
Actions
Navigation
Toolbox